Here’s a very small and practical tip that is forgotten by many companies when designing interfaces: checkboxes or selection boxes should always be told in positive format. For example, if player can tick to enable AntiAlias then the box should look like this:
In no case there should be like this:
The first option is much easier for human brain as there’s only one thing to process: “AntiAlias is enabled”. But in the second case your brain will most likely first check if there’s a ticked box and then it will check word “disabled” and then calculate “disabled is enabled so this means that AntiAliasing is disabled”
Here is another bad example with several options:
Better way would be:
Windowed Screen AutoRun ON Enable Auto-save Script Debugging Maximize Screen Automatically Show additional information
As you can see, there were 2 options (“auto-save” and “maximize screen”) that were okay, but since the other options were in “negative” way is harder to read those options. In the better solution all options are said in “positive” way which makes it easier and faster for user to understand what he has selected.
Same rule could be said for variable naming: always use positive tense in variables. For example a variable “HideCharacter = True” is bad since as the logic is same as “as hide character is true then show character is false which means character is not shown”. If you would use “ShowCharacter = False” then you could read it as “Show character is false so character is not shown”.
The more variables you have the more complex negative tense makes things.