I was messing around putting mouseX, mouseY and mouseHit info in parameters. Since these words were reserved by the programming tool, I thought to just drop one letter from each. mousX and mousY were fine for alternatives for variable names since I couldn’t use mouseX and mouseY. After that, I accidentally wrote moushit (instead of mousHit), which kind of sounds something else than “mouse” and “hit” together.
This reminded me that It’s pretty easy to get yourself into trouble when coming up with names.
In variable naming it might not be too big of a deal, but too bad if this occurs when naming children, or when launching new companies or software or simply when coming up with a game name. Well, I suppose (mou)shit just happens.
You don’t by any chance know any mou-shitty company names?