“One thing* does just one thing.”
(Not exact quote though)
That’s what buddy of mine told me many many years ago. And this is just great piece of advice that helps in making everyday decisions in coding. I was thinking of adding something to “init” function today and was bothering if I make it “quickly”, but then instead of making it quickly I cleaned the codebase a bit. Already feeling great about this small thing.
You can replace first “thing*” with “method”, “function”, “class”, “module” depending on what you are currently doing.